My Post on Tony’s site. HDMI audio enabling.

Follow the post here: I have been trying my hardest 5 days strait to get HDMI audio out form my integrated graphics HD 3000. Here is the hardware I have:

[list=]CPU: Intel i3 2105
MOBO: GA-H61N-USB3 rev. 2 F2 BIOS
*Audio: ALC889
*Video ports: One DVI, One VGA, One HDMI (The DVI is where the HDMI port 1 would be in this board’s sister: GA-H67N-USB3-B3[/list]

[b]Tutorials I have followed to the best of my abilities in enabling HDMI Audio out: [/b]

[url]http://www.tonymacx86.com/viewtopic.php?f=168&t=33412&p=209913#p209913[/url]
[url]http://www.tonymacx86.com/viewtopic.php?f=162&t=31664[/url]

[b]Starting from the top: [/b]

So from URL 2 lets run the check list:

[strikethru]1. Lion (Mac OS X 10.7.x), bootable from hard disc.[/strikethru]
[strikethru]2. DSDT.aml installed in Extras[/strikethru]
[strikethru]3. AppleHDA_v2.1.x installed in System/Library/Extensions[/strikethru]
[strikethru]4. Device (HDEF) present in dsdt. (Working on board audio required for 10.7 or HD3000)[/strikethru]
[strikethru]5. No audio enablers (i.e., Voodoo, 8xxEnabler, etc)[/strikethru]
6. Compatible Graphics:
…..AMD HD 5xxx or HD 6xxx or
…..Nvidia GT 240, GT/S/X 4xx, GT/S/X 5xx or
…..[strikethru]Intel HD3000 Integrated Graphics ([b]i3-2105[/b], i3-2125, i5-2405S, i5-2500K, i7-2600K processors – 9/2011)[/strikethru]
[strikethru]7. Lion Recognized Graphics Card[/strikethru]
…..About This Mac/Graphics: Correct and complete supplier, model and memory
…..System Report…/System Profiler/Graphics/Displays: Television: Yes
…..System Preferences/Displays: 1080p, 1080i or 720p

So, It seems like I qualified so off I went…
I installed 10.7, did a combo update to 10.7.2 then ran Multibeast with UserDSDT. I followed instructions in the enabling HDMI audio edits in patching the DSDT. Below is what I selected from multibeast, and the DSDT patched For enabling HDMI port.

[attachment=4]Screen Shot 2011-12-23 at 2.21.48 AM.png[/attachment]
[b]Note:[/b] In my first attempt, I did not select any audio kext/ drivers. I used v2.1.1 AppHDA.kext and followed through part 3 from toleda’s HDMI tutorial. After many unsuccessful attempts, I settled with using the ALC8xxHDA with rollback option in multibeast. If you read on you’ll understand what I’m getting at…

[attachment=3]AppleHDA.kext.zip[/attachment]
This kext is what I used to edit, not audio kext were installed by me at this point. I once went by Method A (tony’s link, 3rd URL above) and once by Method B (manual edits). This version of AppleHDA kext is v2.1.1.

[attachment=2]dsdt.aml[/attachment]
Here is a copy of my finished DSDT, patched as per the tutorial. Basically the finished product of Part 2b and first parts of 3c. Note the device IGD0 was renamed to IGPU. The DSDT compiled and installed successfully.

[b] What these edits successfully allowed me to do:[/b]

With the DSDT patched, I could now boot the OS with my HDMI cable plugged in. Before the system would get stuck booting at the apple grey screen. Did not document the verbose mode because it was expected not to work. But now it does thanks to the edits on the DSDT. I still cannot get into lion’s installer with HDMI port, also expected.

With AppleHDA audio kext edits and via ALC8xxHDA kext and rollback option It enabled and showed audio devices in my audio settings. I had outputs listed as follows:

[u]Audio Out-puts:[/u]
*Internal Speaker (rear green port turned into headphone out) when front jack was plugged into.
*Line Out (doesn’t work)
*Optical out (works 🙂 )

So front and back green analog ports work for audio along with Toslink. Yay. But now for HDMI audio out…. Marching on….

[b]A bit more detail in what all I did in Kext edits Part 3c in tutorial:[/b]

Before I begin..
[u] a part I didn’t really understand in the tutorial…[/u]

[quote] AppleHDAHardwareConfigDriver.kext /Info.plist Edit
Includes: CodecID, LayoutID, PinConfigurations

1. Copy your unedited AppleHDA.kext to Desktop. Make sure it’s v2.1.1 or later.
Right-click AppleHDA.kext and choose Show Package Contents …. [/quotes]

What is AppleHDAHardwareConfigDriver.kext? I can’t find this kext in my extensions folder and also the next steps refers to the AppleHDA.kext not configDriver.kext… I was a bit confused about that section…

[b]So checklist of AppleHDA’s edits:[/b]
of HDAConfigDefault Remove all configurations (1-17) except 0 and edit as suggested.
Save and copy edited layout889.xml to AppleHDA.kext/Contents/Resources.
Open AppleHDA.kext/Contents/MacOS/AppleHDA binary file using Hex Fiend/HexEdit and replace as suggested.
Install AppleHDA.kext

With all this done, I have provided my edited AudioHDA kext v2.1.1 below. (note. The tuneup kit v3 has an edited platforms.xml, should I have done any edits to mine? None the less I tried tune up kit v3 as well with a fresh install of Lion, I cannot boot into OS giving me an error in Verbose Mode I discuss later in this post…..

With these edits to the AppleHDA kext, I am able to have analog audio output at least.

[attachment=1]AppleHDA.kext.zip[/attachment]

[b]Where things mess up for me[/b]

[quote] This guide applies to Mac OS X 10.7.1 and 10.7.2, 64 bit only.
10.7.2 Update:
1. AppleIntelHD3000Graphics.kext added, AppleIntelHDGraphicsFB.kext does not load for HD3000
2. AppleIntelSNBGraphicsFB.kext macbookpro8,1 framebuffer connector table changed
3. AppleHDA.kext updated to v2.1.3, no change to edits.
Best news, for those with a HDMI connector on the motherboard assigned to port 0x7, you can now boot successfully on HDMI without the “main graphics hang” errors.[/quote][/quote]

Remember, I am running 10.7.2, so will this mess me up when I edit AppleIntelHDGraphicsFB.kext? Do I need to mess with AppleIntelHD30000Graphics.Kext? Does My MOBO have an HDMI connector port assigned to 0x7? How can I check? It is true that I can boot successfully on HDMI, though my MOBO has 1 HDMI port and the GA-H67N-USB3-B3 MOBO has 2. Am I Thinking too much?

Okay, so below is the part where when I make changes, it messes me up booting into my Lion install. It has to do with the the particular Kext: AppleIntelHDGraphicsFB.kext.

[u]Checklist of AppleHDGraphicsFB.kext’s edits[/u]

*Open AppleIntelSNBGraphicsFB.kext/Contents/MacOS/AppleIntelSNBGraphicsFB binary file
using HexEdit or Hex Fiend and make edits as suggested:
* macmini5,1 – edited
00 02 03 00 00 00 00 00 ff ff ff ff
02 05 00 00 00 08 00 00 06 00 00 00
03 04 00 00 00 04 00 00 07 00 00 00
04 06 00 00 00 04 00 00 09 00 00 00
*Install Kext and reboot with HDMI plugged in.

When I reboot, I get stuck at the Grey loading Apple screen during boot. In verbose Mode I get the error below provided in the image. Below I have also supplied readers with my edited AppleIntelHDGraphicsFB.kext.

[attachment=0]2011-12-21 04.27.04.jpg[/attachment]
Anyone know of this error? Can anyone point me to the right direction to what to look into so I can fix this?

[attachment=10]AppleIntelHDGraphicsFB.kext[/attachment]
Blah, I hate this kext… Even when I use the Tune up Kit v3, I can’t bot due to this edited kext.
[b]Summery…[/b]
So I still don’t have HDMI audio Out, Right now I have installed the ALC8xxxHDA kexts with rollback option in multibeast making most of analog audio. I want HDMI audio to work best because it enables my Customini portability with less wires, plus this hack is for my parents for heir Christmas present. Heh, time is running out I guess… They aren’t tech savy so if I Tell them plug in HDMI and Power and use your (preconfigured) ipad with app or iPhone wth app to control your hackintosh, be happy and merry for the rest of the year…. Wouldn’t be to hard to follow. I hope I have supplied you with enough information, need more just ask. Im learning quick, this was my first time Kext editing and DSDT patching, for that I give MUCH thanks to Toleda and your wonderfuly detailed tutorial. Can’t thank you enough. Also Tonymac and the community. Merry Christmas all.

Advertisements